Coding.NET › 轻量级社交
› 开源项目广场
› 使用帮助
› 意见反馈
hitoriga
V2EX  ›  Coding

MS SQLServer 的 VARCHAR/NVARCHAR 类型既然是变长的,为什么不直接用最大值呢?

  •  1
     
  •   hitoriga · Oct 21, 2019 · 9129 views
    This topic created in 2531 days ago, the information mentioned may be changed or developed.

    比如备注这样的字段,因为数据表中给它的长度不够,导致经常报这样的错误: System.InvalidOperationException: String 或 binary 数据将被截断。

    上次加到 500 这次报错改成 nvarchar(1000),下次再报错的话是不是该改成 2000 了。

    既然 varchar/nvarchar 可变长,不会因为没用满导致空间浪费,何不把这样的字段都设成 nvarchar(4000)或者 varchar(8000)呢? 不过我司好像没人这么整,是因为这样做有啥问题吗

    No Comments Yet
    About   ·   Help   ·   Advertise   ·   Blog   ·   API   ·   FAQ   ·   Privacy   ·   Solana   ·   2557 Online   Highest 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 27ms · UTC 01:38 · PVG 09:38 · LAX 18:38 · JFK 21:38
    ♥ Do have faith in what you're doing.