V2EX = way to explore
V2EX 是一个关于分享和探索的地方
Sign Up Now
For Existing Member  Sign In
V2EX  ›  css3  ›  全部回复第 7 页 / 共 52 页
回复总数  1026
1 ... 3  4  5  6  7  8  9  10  11  12 ... 52  
❮ ❯
2022 年 11 月 10 日
回复了 css3 创建的主题 › 程序员 › k8s port-forward 开放的端口在集群外是不能访问的吗?
@yasi
@MrSheng 试了 spark 可以
2022 年 11 月 9 日
回复了 css3 创建的主题 › 程序员 › k8s port-forward 开放的端口在集群外是不能访问的吗?
尝试转发了 elasticsearc ,集群外已经能请求是通的,但是服务不可用
kubectl port-forward -n debug svc/elasticsearch 32345:9200 --address 0.0.0.0 # 集群外浏览器访问时,命令行报以下错:
Forwarding from 0.0.0.0:32345 -> 9200
Handling connection for 32345
E1109 20:49:19.449246 2732386 portforward.go:400] an error occurred forwarding 32345 -> 9200: error forwarding port 9200 to pod 363e34776981b5357de40b6139fd9ee2c978a05eebd1a5f7932b7bf3868930f2, uid : exit status
1: 2022/11/09 20:49:19 socat[541516] E connect(5, AF=2 127.0.0.1:9200, 16): Connection refused

但我用:kubect expose svc -n debug elasticsearch --name elasticsearch-svc --type=NodePort 后,集群外浏览器能正常访问 es 的版本页面

请问下大家这是咋回事啊, 是这么用的吗


@Judoon
@yasi
@MrSheng
@ospider
2022 年 11 月 9 日
回复了 css3 创建的主题 › 程序员 › k8s port-forward 开放的端口在集群外是不能访问的吗?
@MrSheng 感谢感谢,就是少了 --address 0.0.0.0 这个参数,导致集群外无法访问
2022 年 11 月 8 日
回复了 css3 创建的主题 › 程序员 › k8s port-forward 开放的端口在集群外是不能访问的吗?
@imnpc 跨版本恢复不了吧? 15 的资料恢复到 16 ?
@totoro625 没有使用 iCloud ,相册有 50G
2022 年 10 月 26 日
回复了 css3 创建的主题 › 问与答 › vscode 如何使用 docker 镜像内的 Python 解释器?
@zzm88104 咦,这样确实可以,但是还得给容器里装 python 插件,选择了 python 解释器后。导包仍然无法识别,看上去不能正常 work ,要研究下,如果能搞正常,这样也还行
2022 年 10 月 26 日
回复了 css3 创建的主题 › 问与答 › vscode 如何使用 docker 镜像内的 Python 解释器?
@villivateur docker desktop 吃资源厉害啊
2022 年 10 月 25 日
回复了 css3 创建的主题 › 问与答 › 如何克服白大褂高血压心态
@erwin985211 40 年好久啊,有每天服药吗?
2022 年 10 月 25 日
回复了 css3 创建的主题 › 问与答 › 如何克服白大褂高血压心态
@bglucas 刚出炉的,窦性心律,左室高电压
2022 年 10 月 25 日
回复了 css3 创建的主题 › 问与答 › 如何克服白大褂高血压心态
@billgong 我没有用,越发去想着如何克服,越发在乎,越发紧张到窒息,心跳到飞起,量出来越高,我都有点想大嘴巴抽自己了
@MoonWalker 公网服务器指的公网 IP 地址啊
2022 年 10 月 23 日
回复了 amiee0599 创建的主题 › 问与答 › 之前很火的 16 型人格测试,你们都是什么?
物流师
@ye4tar
nginx 没有我没有尝试通过, 还是通过 ssh 实现了
ssh -NfR 0.0.0.0:remote_port:localhost:web_port 公网服务器
ssh -NfL 公网服务器:port:127.0.0.1:remote_port 公网服务器
@ye4tar 直接在 B 内 ssh 进入 A ,是因为开了 autossh 做了端口转发啊
@ye4tar 按你这个配置了,没有用,A 的 web http://172.9.52.1:5002 在 A 上 curl 命令是可访问的,然后通过以下 nginx 配置转到 B 的 5003 , 在 B 上 curl IP:5003 curl: (7) Failed to connect to x.x.x.x port 5003: Connection refused
server {
listen 5003;
listen [::]:5003;
server_name _;
root /data/web/;

location /api/ {
proxy_pass http://172.9.52.1:5002/;
}
}
~
而且我也完全不能理解,proxy_passproxy_pass http://172.9.52.1:5002/;,A 的 IP 对于 B 来说,是不通的啊, 这里配了 A 的 IP 有啥用啊
@wu00
@ye4tar
A 没有公网,B 的 nginx 转发到 A , 这个操作具体要在 B 的 nginx 配置 A 的啥值?
目前是这样的:
ssh -R 0.0.0.0:5003:localhost:5002 -p internet_server
5003 通过路由配置转发到公网了
1 ... 3  4  5  6  7  8  9  10  11  12 ... 52  
❮ ❯
About   ·   Help   ·   Advertise   ·   Blog   ·   API   ·   FAQ   ·   Privacy   ·   Solana   ·   2378 Online   Highest 6679   ·     Select Language
创意工作者们的社区
World is powered by solitude
VERSION: 3.9.8.5 · 20ms · UTC 11:43 · PVG 19:43 · LAX 04:43 · JFK 07:43
♥ Do have faith in what you're doing.